<!DOCTYPE html> <html lang="en-US"> <head> <meta charset="UTF-8" /> <meta name="description" content="On the CSI: Vegas episode &#039;Burned,&#039; a mysterious bigfoot-like footprint found near a crime scene puzzles the CSI team. A father and son were killed, burned to death, after the Sasquatch figure left the house." /> <meta name="viewport" content="width=device-width, initial-scale=1" /> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:creator" content="@2paragraphs"> <meta name="twitter:site" content="@2paragraphs"> <meta property="og:title" content="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;"> <meta property="og:description" content="On the CSI: Vegas episode &#039;Burned,&#039; a mysterious bigfoot-like footprint found near a crime scene puzzles the CSI team as they work to uncover who – or what – killed a father and son. The two were"> <meta property="og:image" content="https://2paragraphs.com/wp-content/uploads/2022/11/csi-vegas.jpg"> <title>&#8216;CSI: Vegas&#8217; Investigates Bigfoot Suspect In Father and Son Murders </title> <meta name='robots' content='max-image-preview:large' /> <link rel='dns-prefetch' href='//ws.sharethis.com' /> <link rel='dns-prefetch' href='//s.w.org' /> <link rel="alternate" type="application/rss+xml" title="Entertainment, TV, Celebrity, Culture &raquo; Feed" href="https://2paragraphs.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="Entertainment, TV, Celebrity, Culture &raquo; Comments Feed" href="https://2paragraphs.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="Entertainment, TV, Celebrity, Culture &raquo; &#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221; Comments Feed" href="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/feed/" /> <link rel="canonical" href="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" /> <meta property="og:title" content="&#8216;CSI: Vegas&#8217; Investigates Bigfoot Suspect In Father and Son Murders" /> <meta property="og:type" content="article" /> <meta property="og:description" content="On the CSI: Vegas episode &#039;Burned,&#039; a mysterious bigfoot-like footprint found near a crime scene puzzles the CSI team. A father and son were killed, burned to death, after the Sasquatch figure left the house." /> <meta property="og:url" content="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" /> <meta property="og:image" content="https://2paragraphs.com/wp-content/uploads/2022/11/csi-vegas.jpg" /> <meta property="og:image:width" content="1219" /> <meta property="og:image:height" content="695" /> <meta property="og:image:alt" content="CSI Vegas" /> <script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/2paragraphs.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.5"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script> <style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style> <link rel='stylesheet' id='2paragraphs-theme-css' href='https://2paragraphs.com/wp-content/themes/tp-child/style.css?ver=1.0' type='text/css' media='all' /> <link rel='stylesheet' id='wp-block-library-css' href='https://2paragraphs.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.5' type='text/css' media='all' /> <style id='global-styles-inline-css' type='text/css'>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</style> <link rel='stylesheet' id='ssbp_styles-css' href='https://2paragraphs.com/wp-content/plugins/simple-share-buttons-plus/ssbp.min.css?ver=5.9.5' type='text/css' media='all' /> <link rel='stylesheet' id='cookie-notice-front-css' href='https://2paragraphs.com/wp-content/plugins/cookie-notice/css/front.min.css?ver=5.9.5' type='text/css' media='all' /> <script id='st_insights_js' type='text/javascript' src='https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simple-share-pro' id='ssbp-sharethis-js'></script> <script type='text/javascript' src='https://2paragraphs.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script type='text/javascript' src='https://2paragraphs.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script type='text/javascript' id='cookie-notice-front-js-extra'>
/* <![CDATA[ */
var cnArgs = {"ajaxUrl":"https:\/\/2paragraphs.com\/wp-admin\/admin-ajax.php","nonce":"4cbfb24a9e","hideEffect":"fade","position":"bottom","onScroll":"0","onScrollOffset":"100","onClick":"0","cookieName":"cookie_notice_accepted","cookieTime":"2592000","cookieTimeRejected":"2592000","globalCookie":"0","redirection":"0","cache":"1","refuse":"0","revokeCookies":"0","revokeCookiesOpt":"automatic","secure":"1"};
/* ]]> */
</script> <script async type='text/javascript' src='https://2paragraphs.com/wp-content/plugins/cookie-notice/js/front.min.js?ver=2.4.2' id='cookie-notice-front-js'></script> <link rel="https://api.w.org/" href="https://2paragraphs.com/wp-json/" /><link rel="alternate" type="application/json" href="https://2paragraphs.com/wp-json/wp/v2/posts/220472" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://2paragraphs.com/xmlrpc.php?rsd" /> <link rel="alternate" type="application/json+oembed" href="https://2paragraphs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2F2paragraphs.com%2F2022%2F11%2Fcsi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://2paragraphs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2F2paragraphs.com%2F2022%2F11%2Fcsi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part%2F&#038;format=xml" /> <script>
    document.cookie = "cookie_notice_accepted=true;max-age=" + 3600*24*365 + "; path=/" + ";secure;";
    document.cookie = "cookie_notice_accepted=true;max-age=" + 3600*24*365 + "; path=/";
    if ( ! /(^|;)\s*cca_is_eu=/.test(document.cookie) ) {  // if check prevents reload loop
		  document.cookie = "cca_is_eu=false;max-age=" + 3600*24*364 + "; path=/";
      var ccaURL = window.location.protocol + '//',
      hostname = window.location.host + '/' + window.location.pathname;
			if ( '0' === '1' ) {
        window.location.reload( true );
      }
   }
</script> <script>
			  window.fbAsyncInit = function() {
				FB.init({
				  appId      : '',
				  xfbml      : true,
				  version    : 'v2.6'
				});
			  };

			  (function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));
			</script> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-30569204-1"></script> <script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-30569204-1');
</script> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-3005869422371895",
          enable_page_level_ads: true
     });
</script> <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script> <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script> <script async src="http://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-3005869422371895",
enable_page_level_ads: true,
tag_partner: "genesis"
});
</script> <script type="text/javascript">
		jQuery(document).ready(function($) {

			$(".nav-social .like-button").hover(
				function () {
					$(this).addClass("active");
				},
				function () {
					$(this).removeClass("active");
				}
			);

			$(".nav-social .tweet-button").hover(
				function () {
					$(this).addClass("active");
				},
				function () {
					$(this).removeClass("active");
				}
			);

			$(".nav-social .search-button").on("click", function(){
				$(".search-bar").addClass("active");
			});

			$(".mobile-search").on("click", function(){
				$(".search-bar").addClass("active");
			});

			$(".mobile-menu-primary").on("click", function(){
				$(".menu-primary").slideToggle();
				$(this).toggleClass("active");
			});

			$(".mobile-search").on("click", function(){
				$(".nav-search form").slideToggle();
				$(this).toggleClass("active");
			});

			// SIDEBAR TABS FOR TRENDING AND POPULAR POSTS
			$(".tab-content").hide();
			$("ul.tabs li:first").addClass("active").show();
			$(".tab-content:first").show();
			$("ul.tabs li").click(function() {
				$("ul.tabs li").removeClass("active");
				$(this).addClass("active");
				$(".tab-content").hide();
				var activeTab = $(this).find("a").attr("href");
				$(activeTab).show();
				return false;
			});

			// FIXED MOBILE NAVIGATION
			var header = $(".navigation");
			$(window).scroll(function() {    
				var scroll = $(window).scrollTop();
				if (scroll >= 123) {
					header.addClass("fixed-nav");
				} else {
					header.removeClass("fixed-nav");
				}
			});

		});
	</script> <script type="text/javascript">
		(function() {
			var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
			po.src = 'https://apis.google.com/js/platform.js';
			var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
		})();
	</script> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script> <meta name="onesignal" content="wordpress-plugin" /> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://2paragraphs.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '58a4a4c2-16c9-4924-b50c-954a96b50148';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "You rock!";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing!";
oneSignal_options['welcomeNotification']['url'] = "https://2paragraphs.com";
oneSignal_options['path'] = "https://2paragraphs.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.2e92f9d5-12a5-4675-93ec-24ce5a91bfb8";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = "2paragraphs wants to show you notifications!";
oneSignal_options['promptOptions']['siteName'] = "2paragraphs";
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script> <link rel="amphtml" href="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/amp/"> <script type="text/javascript">
		jQuery(document).ready(function($) {
			$('.entry').attr('id', 'entry');
		});
	</script> <link rel="icon" href="https://2paragraphs.com/wp-content/uploads/2016/10/cropped-2plogo512-1-32x32.jpg" sizes="32x32" /> <link rel="icon" href="https://2paragraphs.com/wp-content/uploads/2016/10/cropped-2plogo512-1-192x192.jpg" sizes="192x192" /> <link rel="apple-touch-icon" href="https://2paragraphs.com/wp-content/uploads/2016/10/cropped-2plogo512-1-180x180.jpg" /> <meta name="msapplication-TileImage" content="https://2paragraphs.com/wp-content/uploads/2016/10/cropped-2plogo512-1-270x270.jpg" /> </head> <body class="post-template-default single single-post postid-220472 single-format-standard header-full-width content-sidebar genesis-breadcrumbs-visible cookies-not-set" itemscope itemtype="https://schema.org/WebPage"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="site-container"><div id="fb-root"></div> <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=311944986724";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://2paragraphs.com/">Entertainment, TV, Celebrity, Culture</a></p></div> <div class="social nav-social"> <div class="like-button"> <div class="fb-like" data-href="http://2paragraphs.com" data-layout="button" data-action="like" data-show-faces="false" data-share="false"></div> </div> <div class="tweet-button"> <a href="https://twitter.com/2Paragraphs" class="twitter-follow-button" data-show-count="false" data-show-screen-name="false">Follow @2Paragraphs</a> </div> <div class="search-button"> <div class="search-button"></div> </div> </div> <div class="mobile-menu-primary"><span class="top"></span><span class="middle"></span><span class="bottom"></span></div> <div class="mobile-search"><span class="top"></span><span class="middle"></span><span class="bottom"></span></div> </div></header> <div class="search-bar"> <div class="wrap"> <form method="get" class="search-form" action="https://2paragraphs.com" role="search"><input type="search" name="s" placeholder="to search, type and hit enter"></form> </div> </div> <div class="navigation"> <nav class="nav-primary" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <div class="wrap"> <ul id="menu-sub" class="menu genesis-nav-menu menu-primary"> <li id="menu-item-5497" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5497"> <a href="https://2paragraphs.com/category/daily-edition/">Daily Edition</a> <ul class="cat-latest"> <li> <a href="https://2paragraphs.com/2022/11/giddy-barack-obama-jumps-into-biden-video-the-cutest-couple/" title="Permalink to Giddy Barack Obama Jumps Into Biden Video, &#8220;The Cutest Couple&#8221;"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/President_Barack_Obama_cropped_with_flag-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Barack Obama" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/President_Barack_Obama_cropped_with_flag-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/President_Barack_Obama_cropped_with_flag-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/President_Barack_Obama_cropped_with_flag-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Giddy Barack Obama Jumps Into Biden Video, &#8220;The Cutest Couple&#8221; </a> </li> <li> <a href="https://2paragraphs.com/2022/11/jemele-hill-says-kyrie-irvings-anti-semitism-is-used-as-a-pretext/" title="Permalink to Jemele Hill Says Kyrie Irving&#8217;s Anti-Semitism Is Used as a &#8220;Pretext&#8221;"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/10/Kyrie_Irving_during_the_2016_NBA_Champions_victory_parade-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Kyrie_Irving" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/10/Kyrie_Irving_during_the_2016_NBA_Champions_victory_parade-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/10/Kyrie_Irving_during_the_2016_NBA_Champions_victory_parade-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/10/Kyrie_Irving_during_the_2016_NBA_Champions_victory_parade-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Jemele Hill Says Kyrie Irving&#8217;s Anti-Semitism Is Used as a &#8220;Pretext&#8221; </a> </li> <li> <a href="https://2paragraphs.com/2022/11/gop-dems-agree-on-harsh-gun-crime-sentences-could-that-soon-change-study/" title="Permalink to GOP, Dems Agree On Harsh Gun Crime Sentences &#8212; Could That Soon Change? Study"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/Wapato_Correctional_Facility_upper_floor-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Correctional_Facility_" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/Wapato_Correctional_Facility_upper_floor-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/Wapato_Correctional_Facility_upper_floor-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/Wapato_Correctional_Facility_upper_floor-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />GOP, Dems Agree On Harsh Gun Crime Sentences &#8212; Could That Soon Change? Study </a> </li> </ul> </li> <li id="menu-item-15854" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15854"> <a href="https://2paragraphs.com/category/business-spotlight/">Business</a> <ul class="cat-latest"> <li> <a href="https://2paragraphs.com/2022/11/mark-cuban-wants-elon-musk-to-hear-this-from-one-entrepreneur-to-another/" title="Permalink to Mark Cuban Wants Elon Musk To Hear This, &#8220;From One Entrepreneur To Another&#8221;"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2021/11/Elon_Musk-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Elon_Musk" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2021/11/Elon_Musk-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2021/11/Elon_Musk-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2021/11/Elon_Musk-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Mark Cuban Wants Elon Musk To Hear This, &#8220;From One Entrepreneur To Another&#8221; </a> </li> <li> <a href="https://2paragraphs.com/2022/10/elon-musk-could-have-bought-half-the-nba-for-his-44-billion-twitter-po/" title="Permalink to Elon Musk Could Have Bought Half the NBA for His $44 Billion Twitter PO"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2021/11/Elon_Musk-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Elon_Musk" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2021/11/Elon_Musk-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2021/11/Elon_Musk-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2021/11/Elon_Musk-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Elon Musk Could Have Bought Half the NBA for His $44 Billion Twitter PO </a> </li> <li> <a href="https://2paragraphs.com/2022/10/jim-cramers-emotional-meta-apology-reminds-of-painful-bear-stearns-is-fine-moment/" title="Permalink to Jim Cramer&#8217;s Emotional Meta Apology Reminds of Painful &#8220;Bear Stearns Is Fine!&#8221; Moment"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/10/Jimcramerphoto-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Jim Cramer Mad Money" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/10/Jimcramerphoto-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/10/Jimcramerphoto-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/10/Jimcramerphoto-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Jim Cramer&#8217;s Emotional Meta Apology Reminds of Painful &#8220;Bear Stearns Is Fine!&#8221; Moment </a> </li> </ul> </li> <li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"> <a href="https://2paragraphs.com/category/culture/">Culture</a> <ul class="cat-latest"> <li> <a href="https://2paragraphs.com/2022/11/christmas-on-mistletoe-lake-teen-star-is-voice-of-sally-in-snoopy-movies/" title="Permalink to &#8216;Christmas on Mistletoe Lake&#8217; Teen Star Is Voice of Sally in Snoopy Movies"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/Genelle-Williams--150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Christmas on Mistletoe Lake" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/Genelle-Williams--150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/Genelle-Williams--75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/Genelle-Williams--290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />&#8216;Christmas on Mistletoe Lake&#8217; Teen Star Is Voice of Sally in Snoopy Movies </a> </li> <li> <a href="https://2paragraphs.com/2022/11/law-order-svu-star-molly-burnett-as-blond-lingerie-model-looks-totally-different/" title="Permalink to &#8216;Law &#038; Order SVU&#8217; Star Molly Burnett as Blond Lingerie Model, Looks Totally Different"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/Molly-Burnett-Law-and-Order-SVU-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Molly Burnett" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/Molly-Burnett-Law-and-Order-SVU-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/Molly-Burnett-Law-and-Order-SVU-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/Molly-Burnett-Law-and-Order-SVU-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />&#8216;Law &#038; Order SVU&#8217; Star Molly Burnett as Blond Lingerie Model, Looks Totally Different </a> </li> <li> <a href="https://2paragraphs.com/2022/11/station-19-carina-and-maya-get-more-heated-in-lightning-storm-fall-finale/" title="Permalink to &#8216;Station 19&#8217;: Carina and Maya Get &#8220;More Heated&#8221; in Lightning Storm, Fall Finale"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/05/station-19-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="DANIELLE SAVRE, STEFANIA SPAMPINATO" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/05/station-19-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/05/station-19-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/05/station-19-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />&#8216;Station 19&#8217;: Carina and Maya Get &#8220;More Heated&#8221; in Lightning Storm, Fall Finale </a> </li> </ul> </li> <li id="menu-item-2058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2058"> <a href="https://2paragraphs.com/category/sports/">Sports</a> <ul class="cat-latest"> <li> <a href="https://2paragraphs.com/2022/11/this-michael-jordan-killer-wants-his-chicago-respect-heres-the-case-against-mj/" title="Permalink to This Michael Jordan Killer Wants His Chicago Respect, Here&#8217;s The Case Against MJ"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2021/09/Michael_Jordan_and_Barack_Obama_at_the_White_House-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Michael_Jordan_and_Barack_Obama" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2021/09/Michael_Jordan_and_Barack_Obama_at_the_White_House-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2021/09/Michael_Jordan_and_Barack_Obama_at_the_White_House-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2021/09/Michael_Jordan_and_Barack_Obama_at_the_White_House-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />This Michael Jordan Killer Wants His Chicago Respect, Here&#8217;s The Case Against MJ </a> </li> <li> <a href="https://2paragraphs.com/2022/11/shaq-turns-to-deion-sanders-to-shut-down-new-haters-ill-tell-you-what-i-am/" title="Permalink to Shaq Turns To Deion Sanders To Shut Down New Haters, &#8220;I&#8217;ll Tell You What I Am&#8221;"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/05/Shaquille_ONeal_October_2017-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Shaquille_O&#039;Neal" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/05/Shaquille_ONeal_October_2017-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/05/Shaquille_ONeal_October_2017-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/05/Shaquille_ONeal_October_2017-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Shaq Turns To Deion Sanders To Shut Down New Haters, &#8220;I&#8217;ll Tell You What I Am&#8221; </a> </li> <li> <a href="https://2paragraphs.com/2022/11/nets-coach-jacque-vaughn-popovich-guy-coached-brooklyn-before-with-700-win-percentage/" title="Permalink to Nets Coach Jacque Vaughn, Popovich Guy, Coached Brooklyn Before With .700 Win Percentage"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2021/09/NBA_Small_Forward_Kevin_Durant-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="NBA_Small_Forward_Kevin_Durant" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2021/09/NBA_Small_Forward_Kevin_Durant-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2021/09/NBA_Small_Forward_Kevin_Durant-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2021/09/NBA_Small_Forward_Kevin_Durant-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Nets Coach Jacque Vaughn, Popovich Guy, Coached Brooklyn Before With .700 Win Percentage </a> </li> </ul> </li> <li id="menu-item-4036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4036"> <a href="https://2paragraphs.com/category/food/">Food</a> <ul class="cat-latest"> <li> <a href="https://2paragraphs.com/2022/09/mcdonalds-sweetens-menu-revives-cheese-danish-pastry-for-mccafe-coffee-lovers/" title="Permalink to McDonald&#8217;s Sweetens Menu, Revives Cheese Danish Pastry for McCafé Coffee Lovers"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2019/09/McDonalds-McCafe-TV-commercial-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="McDonalds McCafe TV commercial" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2019/09/McDonalds-McCafe-TV-commercial-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2019/09/McDonalds-McCafe-TV-commercial-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2019/09/McDonalds-McCafe-TV-commercial-290x290.jpg 290w, https://2paragraphs.com/wp-content/uploads/2019/09/McDonalds-McCafe-TV-commercial-550x550.jpg 550w, https://2paragraphs.com/wp-content/uploads/2019/09/McDonalds-McCafe-TV-commercial-470x470.jpg 470w" sizes="(max-width: 150px) 100vw, 150px" />McDonald&#8217;s Sweetens Menu, Revives Cheese Danish Pastry for McCafé Coffee Lovers </a> </li> <li> <a href="https://2paragraphs.com/2022/08/ellen-pompeo-eats-267-baked-potato-at-martha-stewarts-chic-vegas-dinner-party/" title="Permalink to Ellen Pompeo Eats $267 Baked Potato at Martha Stewart&#8217;s Chic Vegas Dinner Party"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2021/10/ellen-pompeo-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Ellen Pompeo" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2021/10/ellen-pompeo-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2021/10/ellen-pompeo-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2021/10/ellen-pompeo-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Ellen Pompeo Eats $267 Baked Potato at Martha Stewart&#8217;s Chic Vegas Dinner Party </a> </li> <li> <a href="https://2paragraphs.com/2022/08/martha-stewart-rocks-yellow-feather-dress-in-vegas-snoop-dogg-pulls-epic-surprise/" title="Permalink to Martha Stewart Rocks Yellow Feather Dress In Vegas, Snoop Dogg &#8220;Pulls Epic Surprise&#8221;"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2021/08/Martha_Stewart-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Martha Stewart" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2021/08/Martha_Stewart-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2021/08/Martha_Stewart-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2021/08/Martha_Stewart-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Martha Stewart Rocks Yellow Feather Dress In Vegas, Snoop Dogg &#8220;Pulls Epic Surprise&#8221; </a> </li> </ul> </li> <li id="menu-item-37" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37"> <a href="https://2paragraphs.com/category/solo_interviews/">Interviews</a> <ul class="cat-latest"> <li> <a href="https://2paragraphs.com/2017/09/do-cranberries-really-help-uti-a-doctor-answers-with-new-evidence/" title="Permalink to Do Cranberries Really Help UTI? A Doctor Answers With New Evidence"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2017/09/Cranberries_in_a_bucket-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Cranberries_in_a_bucket" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2017/09/Cranberries_in_a_bucket-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2017/09/Cranberries_in_a_bucket-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2017/09/Cranberries_in_a_bucket-290x290.jpg 290w, https://2paragraphs.com/wp-content/uploads/2017/09/Cranberries_in_a_bucket-550x550.jpg 550w, https://2paragraphs.com/wp-content/uploads/2017/09/Cranberries_in_a_bucket-470x470.jpg 470w" sizes="(max-width: 150px) 100vw, 150px" />Do Cranberries Really Help UTI? A Doctor Answers With New Evidence </a> </li> <li> <a href="https://2paragraphs.com/2017/08/video-the-speech-ring-inventor-on-overcoming-fear-of-public-speaking/" title="Permalink to Video: The Speech Ring Inventor on Overcoming Fear of Public Speaking"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2017/08/Lauren-Lovett-The-Speech-Ring-Inventor-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Lauren Lovett The Speech Ring Inventor" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2017/08/Lauren-Lovett-The-Speech-Ring-Inventor-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2017/08/Lauren-Lovett-The-Speech-Ring-Inventor-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2017/08/Lauren-Lovett-The-Speech-Ring-Inventor-290x290.jpg 290w, https://2paragraphs.com/wp-content/uploads/2017/08/Lauren-Lovett-The-Speech-Ring-Inventor-470x470.jpg 470w" sizes="(max-width: 150px) 100vw, 150px" />Video: The Speech Ring Inventor on Overcoming Fear of Public Speaking </a> </li> <li> <a href="https://2paragraphs.com/2017/03/first-out-gay-movie-superhero-surge-speaks-on-humor-responsibility/" title="Permalink to First Out Gay Movie Superhero Surge Speaks on Humor, Responsibility"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2017/03/Surge-full-body-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Surge first out gay superhero in the movies" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2017/03/Surge-full-body-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2017/03/Surge-full-body-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2017/03/Surge-full-body-290x290.jpg 290w, https://2paragraphs.com/wp-content/uploads/2017/03/Surge-full-body-470x470.jpg 470w" sizes="(max-width: 150px) 100vw, 150px" />First Out Gay Movie Superhero Surge Speaks on Humor, Responsibility </a> </li> </ul> </li> <li id="menu-item-4408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4408"> <a href="http://2paragraphs.com/category/cool-stuff/">Cool Stuff</a> <ul class="cat-latest"> <li> <a href="https://2paragraphs.com/2022/10/gal-gadot-gets-bubbly-in-zebra-print-dress-for-250-year-old-widow/" title="Permalink to Gal Gadot Gets Bubbly in Zebra Print Dress for 250-Year-Old &#8220;Widow&#8221;"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2021/06/Gal_Gadot-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Gal Gadot" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2021/06/Gal_Gadot-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2021/06/Gal_Gadot-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2021/06/Gal_Gadot-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Gal Gadot Gets Bubbly in Zebra Print Dress for 250-Year-Old &#8220;Widow&#8221; </a> </li> <li> <a href="https://2paragraphs.com/2022/10/smartphone-video-thats-clear-steady-and-stable-try-handheld-gimbal-like-the-pros/" title="Permalink to Smartphone Video That&#8217;s Clear, Steady and Stable? Try Handheld Gimbal Like The Pros"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/10/DJI-Gimbal-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="DJI Osmo Mobile 6 Smartphone Gimbal Stabilizer" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/10/DJI-Gimbal-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/10/DJI-Gimbal-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/10/DJI-Gimbal-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Smartphone Video That&#8217;s Clear, Steady and Stable? Try Handheld Gimbal Like The Pros </a> </li> <li> <a href="https://2paragraphs.com/2022/10/is-dji-avata-camera-drone-on-your-2022-gadget-gift-list-next-level-footage-at-31-mph/" title="Permalink to Is DJI Avata Camera Drone on Your 2022 Gadget Gift List? &#8220;Next Level Footage&#8221; at 31 MPH"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/10/DJI-AVATA-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="DJI AVATA (YouTube)" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/10/DJI-AVATA-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/10/DJI-AVATA-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/10/DJI-AVATA-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Is DJI Avata Camera Drone on Your 2022 Gadget Gift List? &#8220;Next Level Footage&#8221; at 31 MPH </a> </li> </ul> </li> <li id="menu-item-32" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32"> <a href="https://2paragraphs.com/category/bios/">People</a> <ul class="cat-latest"> <li> <a href="https://2paragraphs.com/2019/03/bradley-coopers-net-worth-wealth-soars-100-million-plus/" title="Permalink to Bradley Cooper&#8217;s Net Worth Wealth Soars, $100 Million Plus"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2019/03/Bradley_Cooper_July_2009-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Bradley_Cooper," loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2019/03/Bradley_Cooper_July_2009-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2019/03/Bradley_Cooper_July_2009-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2019/03/Bradley_Cooper_July_2009-290x290.jpg 290w, https://2paragraphs.com/wp-content/uploads/2019/03/Bradley_Cooper_July_2009-470x470.jpg 470w" sizes="(max-width: 150px) 100vw, 150px" />Bradley Cooper&#8217;s Net Worth Wealth Soars, $100 Million Plus </a> </li> <li> <a href="https://2paragraphs.com/2017/08/who-is-barbara-corcorans-fbi-agent-football-star-husband/" title="Permalink to Who Is Barbara Corcoran&#8217;s FBI Agent, Football Star Husband?"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2017/08/Barbara_Corcoran-e1503354187449-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Barbara Corcoran" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2017/08/Barbara_Corcoran-e1503354187449-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2017/08/Barbara_Corcoran-e1503354187449-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2017/08/Barbara_Corcoran-e1503354187449-290x290.jpg 290w, https://2paragraphs.com/wp-content/uploads/2017/08/Barbara_Corcoran-e1503354187449-550x550.jpg 550w, https://2paragraphs.com/wp-content/uploads/2017/08/Barbara_Corcoran-e1503354187449-470x470.jpg 470w" sizes="(max-width: 150px) 100vw, 150px" />Who Is Barbara Corcoran&#8217;s FBI Agent, Football Star Husband? </a> </li> <li> <a href="https://2paragraphs.com/2017/07/watch-espys-pat-tillman-recipient-msgt-del-toro-talk-about-resilience/" title="Permalink to Watch ESPYS Pat Tillman Recipient MSgt. Del Toro Talk About Resilience"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2017/07/U.S._Air_Force_Master_Sgt._Israel_Del_Toro_throws_a_shotput_during_the_2016_Invictus_Games-e1499813303858-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Israel Del Toro" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2017/07/U.S._Air_Force_Master_Sgt._Israel_Del_Toro_throws_a_shotput_during_the_2016_Invictus_Games-e1499813303858-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2017/07/U.S._Air_Force_Master_Sgt._Israel_Del_Toro_throws_a_shotput_during_the_2016_Invictus_Games-e1499813303858-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2017/07/U.S._Air_Force_Master_Sgt._Israel_Del_Toro_throws_a_shotput_during_the_2016_Invictus_Games-e1499813303858-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Watch ESPYS Pat Tillman Recipient MSgt. Del Toro Talk About Resilience </a> </li> </ul> </li> <li id="menu-item-13335" class="no_border menu-item menu-item-type-post_type menu-item-object-page menu-item-13335"> <a href="https://2paragraphs.com/contact/">Contact</a> </li> </ul> </div> </nav> </div> <div class="header-ad"> <div class="wrap"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-3005869422371895" crossorigin="anonymous"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3005869422371895" data-ad-slot="2492661429" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div> </div> <div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-220472 post type-post status-publish format-standard has-post-thumbnail category-culture entry" aria-label="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" itemscope itemtype="https://schema.org/NewsArticle"><header class="entry-header"><h1 class="entry-title" itemprop="headline">&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;</h1> <p class="entry-meta">by <a href="https://2paragraphs.com/author/caitlin-crowther/" title="Posts by Caitlin Crowther" rel="author">Caitlin Crowther</a> in <a href="https://2paragraphs.com/category/culture/" rel="category tag">Culture</a> | November 10, 2022</p> </header><div class="entry-content" itemprop="text"><div class="ssbp-set--one ssbp--state-hidden ssbp-wrap ssbp--centred ssbp--theme-2" data-ssbp-responsive="true"><button class="ssbp-toggle-switch ssbp-toggle-close"><span></span></button><div class="ssbp-container" data-ssbp-share-text="" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-title="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" data-ssbp-short-url="" data-ssbp-post-id="220472"><ul class="ssbp-list"><li class="ssbp-li--facebook"><a data-site="" data-facebook="mobile" class="ssbp-btn ssbp-facebook ssbp-facebook--standard" href="https://www.facebook.com/dialog/share?app_id=775928119208991&display=popup&href=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/&redirect_uri=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/"><span class="ssbp-text">Facebook</span></a></li><li class="ssbp-li--twitter"><a href="https://twitter.com/share?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/&amp;text=%E2%80%98CSI%3A+Vegas%E2%80%99+Investigates+Bigfoot+In+Arson+Murders%2C+%E2%80%9CThat%E2%80%99s+Not+Even+the+Weird+Part%E2%80%9D+&amp;hashtags=" class="ssbp-btn ssbp-twitter ssbp-twitter--standard" data-ssbp-title="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Twitter" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Twitter'); return false;"><span class="ssbp-text">Twitter</span></a></li><li class="ssbp-li--ellipsis"><a href="javascript:;" class="ssbp-btn ssbp-ellipsis" data-ssbp-title="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Ellipsis"><span class="ssbp-text">More</span></a></li><li class="ssbp-li--linkedin"><a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" class="ssbp-btn ssbp-linkedin" data-ssbp-title="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="LinkedIn" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'LinkedIn'); return false;"><span class="ssbp-text">Linkedin</span></a></li><li class="ssbp-li--email"><a href="/cdn-cgi/l/email-protection#142b4761767e71776029312622372c2625222f57475d2e344271737567312622372c2625232f345d7a627167607d737560716734567d73727b7b60345d7a345566677b7a34596166707166673834312622372c2626242f407c7560312622372c2625232f67345a7b60345162717a34607c713443717d66703444756660312622372c2626252f327579642f567b706d293126247c606064672e3b3b2664756675736675647c673a777b793b262426263b25253b77677d396271737567397d7a627167607d737560716739767d73727b7b60397d7a397566677b7a397961667071666739607c756067397a7b60397162717a39607c713963717d667039647566603b" class="ssbp-btn ssbp-email ssbp-email-popup" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Email" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Email'); return false;"><span class="ssbp-text">Email</span></a></li></ul><div class="ssbp-input-url-div"><input class="ssbp-input-url" type="text" value="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" /></div></div></div> <div class="teaser-image large"> <img width="620" height="375" src="https://2paragraphs.com/wp-content/uploads/2022/11/csi-vegas-620x375.jpg" class="attachment-big size-big wp-post-image" alt="CSI Vegas" /> <p class="caption">Mandeep Dhillon as Allie Rajan (Sonja Flemming/CBS)</p> </div> <p>On the <strong><em>CSI: Vegas </em></strong>episode &#8216;Burned,&#8217; a mysterious bigfoot-like footprint found near a crime scene puzzles the CSI team as they work to uncover who – or what – killed a father and son. The two were seemingly burned to death. </p> <figure class="wp-block-image size-large"><a href="https://2paragraphs.com/wp-content/uploads/2022/11/CSI-Vegas-chair.jpg"><img loading="lazy" width="1024" height="683" src="https://2paragraphs.com/wp-content/uploads/2022/11/CSI-Vegas-chair-1024x683.jpg" alt="" class="wp-image-220481" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/CSI-Vegas-chair-1024x683.jpg 1024w, https://2paragraphs.com/wp-content/uploads/2022/11/CSI-Vegas-chair-300x200.jpg 300w, https://2paragraphs.com/wp-content/uploads/2022/11/CSI-Vegas-chair-768x512.jpg 768w, https://2paragraphs.com/wp-content/uploads/2022/11/CSI-Vegas-chair.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /></a><figcaption>Above: Matt Lauria as Josh Folsom on CSI: Vegas, &#8220;Burned&#8221; (Michael Yarish/CBS)</figcaption></figure> <p>The good news is the team has footage from a doorbell camera at the home. Chris Park (<strong>Jay Lee</strong>) tells Agent Maxine Roby (<strong>Paula Newsome</strong>) that the camera caught something that came out of the house but not going in &#8220;<strong>but that&#8217;s not even the weird part</strong>.&#8221; Park then shows Roby the footage. </p> <iframe width='560' height='315' frameborder='0' allowfullscreen src='https://www.paramountpressexpress.com/embed/bc-player-v1.html?video=afh51gs7ip'></iframe> <p>Roby summarizes: &#8220;Okay, so we have a dead father and son. Murdered in a fire. And before the fire starts, Sasquatch runs out.&#8221; Well, it doesn&#8217;t run out, it actually walks out gingerly and even turns toward the camera to reveal a profile. </p> <p><strong><em>CSI: Vegas</em></strong> airs Thursdays at 10 pm ET on CBS, right before <strong><em>So Help Me Todd</em></strong> at 9 pm, <strong><em>Ghosts</em></strong> at 8:30 pm and <strong><em>Young Sheldon</em></strong> at 8 pm.</p> <div class="ssbp-set--one ssbp--state-hidden ssbp-wrap ssbp--centred ssbp--theme-2" data-ssbp-responsive="true"><button class="ssbp-toggle-switch ssbp-toggle-close"><span></span></button><div class="ssbp-container" data-ssbp-share-text="" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-title="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" data-ssbp-short-url="" data-ssbp-post-id="220472"><ul class="ssbp-list"><li class="ssbp-li--facebook"><a data-site="" data-facebook="mobile" class="ssbp-btn ssbp-facebook ssbp-facebook--standard" href="https://www.facebook.com/dialog/share?app_id=775928119208991&display=popup&href=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/&redirect_uri=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/"><span class="ssbp-text">Facebook</span></a></li><li class="ssbp-li--twitter"><a href="https://twitter.com/share?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/&amp;text=%E2%80%98CSI%3A+Vegas%E2%80%99+Investigates+Bigfoot+In+Arson+Murders%2C+%E2%80%9CThat%E2%80%99s+Not+Even+the+Weird+Part%E2%80%9D+&amp;hashtags=" class="ssbp-btn ssbp-twitter ssbp-twitter--standard" data-ssbp-title="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Twitter" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Twitter'); return false;"><span class="ssbp-text">Twitter</span></a></li><li class="ssbp-li--ellipsis"><a href="javascript:;" class="ssbp-btn ssbp-ellipsis" data-ssbp-title="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Ellipsis"><span class="ssbp-text">More</span></a></li><li class="ssbp-li--linkedin"><a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" class="ssbp-btn ssbp-linkedin" data-ssbp-title="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="LinkedIn" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'LinkedIn'); return false;"><span class="ssbp-text">Linkedin</span></a></li><li class="ssbp-li--email"><a href="/cdn-cgi/l/email-protection#66593513040c0305125b435450455e5457505d25352f5c463003010715435450455e5457515d462f08100315120f010712031546240f0100090912462f08462714150908462b1314020314154a46435450455e5454565d320e0712435450455e5457515d1546280912462310030846120e034631030f14024636071412435450455e5454575d40070b165d2409021f5b4354560e121216155c49495416071407011407160e154805090b49545654544957574905150f4b10030107154b0f08100315120f01071203154b040f01000909124b0f084b07141509084b0b1314020314154b120e0712154b0809124b031003084b120e034b11030f14024b1607141249" class="ssbp-btn ssbp-email ssbp-email-popup" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Email" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Email'); return false;"><span class="ssbp-text">Email</span></a></li></ul><div class="ssbp-input-url-div"><input class="ssbp-input-url" type="text" value="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" /></div></div></div></div><footer class="entry-footer"><div class="OUTBRAIN" data-src="DROP_PERMALINK_HERE" data-widget-id="TF_6"></div> <div class="prev-post-from-cat"> <p class="prev-title"><a href="https://2paragraphs.com/2022/11/georgie-meets-mandys-dad-on-young-sheldon-not-carmen-electra/">On &#8216;Young Sheldon&#8217; Georgie Meets Mandy&#8217;s Parents &#8212; It&#8217;s Uncomfortable</a></p> <div class="teaser-image large"> <a href="https://2paragraphs.com/2022/11/georgie-meets-mandys-dad-on-young-sheldon-not-carmen-electra/"><img width="620" height="375" src="https://2paragraphs.com/wp-content/uploads/2022/11/Young-Sheldon-mandys-parents-620x375.jpg" class="attachment-big size-big wp-post-image" alt="Young Sheldon" loading="lazy" /></a> <p class="caption">Young Sheldon (L-R): Rachel Bay Jones, Emily Osment, Montana Jordan, Will Sasso (Robert Voets/Warner Bros)</p> </div> <p class="prev-load-more"><a href="https://2paragraphs.com/2022/11/georgie-meets-mandys-dad-on-young-sheldon-not-carmen-electra/">Load More</a></p> </div> </footer></article></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"> <div class="sidebar-section zero"> </div> <div class="sidebar-section one"> <section class="widget widget-optin"> <div class="widget-wrap"> <iframe src="https://2paragraphs.substack.com/embed" width="auto" height="290" style="border:1px solid #EEE; background:white;" frameborder="0" scrolling="no"></iframe> </div> </section> <section class="widget widget-ad1-mid"> <div class="widget-wrap"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3005869422371895" data-ad-slot="4015753334" data-ad-format="auto"></ins> <script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div> </section> </div> <div class="sidebar-section two"> <section class="widget widget-popular-posts"> <div class="widget-wrap"> <ul class="tabs"> <li><a href="#tab1">Recent</a></li> <li><a href="#tab2">Trending</a></li> <li><a href="#tab3">Popular</a></li> </ul> <div class="tab-container"> <ul id="tab1" class="tab-content"> <li> <a href="https://2paragraphs.com/2022/11/christmas-on-mistletoe-lake-teen-star-is-voice-of-sally-in-snoopy-movies/" title="Permalink to &#8216;Christmas on Mistletoe Lake&#8217; Teen Star Is Voice of Sally in Snoopy Movies"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/Genelle-Williams--150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Christmas on Mistletoe Lake" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/Genelle-Williams--150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/Genelle-Williams--75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/Genelle-Williams--290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />&#8216;Christmas on Mistletoe Lake&#8217; Teen Star Is Voice of Sally in Snoopy Movies </a> </li> <li> <a href="https://2paragraphs.com/2022/11/law-order-svu-star-molly-burnett-as-blond-lingerie-model-looks-totally-different/" title="Permalink to &#8216;Law &#038; Order SVU&#8217; Star Molly Burnett as Blond Lingerie Model, Looks Totally Different"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/Molly-Burnett-Law-and-Order-SVU-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Molly Burnett" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/Molly-Burnett-Law-and-Order-SVU-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/Molly-Burnett-Law-and-Order-SVU-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/Molly-Burnett-Law-and-Order-SVU-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />&#8216;Law &#038; Order SVU&#8217; Star Molly Burnett as Blond Lingerie Model, Looks Totally Different </a> </li> <li> <a href="https://2paragraphs.com/2022/11/station-19-carina-and-maya-get-more-heated-in-lightning-storm-fall-finale/" title="Permalink to &#8216;Station 19&#8217;: Carina and Maya Get &#8220;More Heated&#8221; in Lightning Storm, Fall Finale"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/05/station-19-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="DANIELLE SAVRE, STEFANIA SPAMPINATO" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/05/station-19-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/05/station-19-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/05/station-19-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />&#8216;Station 19&#8217;: Carina and Maya Get &#8220;More Heated&#8221; in Lightning Storm, Fall Finale </a> </li> <li> <a href="https://2paragraphs.com/2022/11/reasonable-doubt-star-emayatzy-corinealdi-played-girlfriend-in-tupak-shakur-video/" title="Permalink to &#8216;Reasonable Doubt&#8217; Star Emayatzy Corinealdi Played Girlfriend in Tupac Shakur Video"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/Reasonable-doubt-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Emayatzy Corinealdi in Reasonable Doubt (hulu screengrab)" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/Reasonable-doubt-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/Reasonable-doubt-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/Reasonable-doubt-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />&#8216;Reasonable Doubt&#8217; Star Emayatzy Corinealdi Played Girlfriend in Tupac Shakur Video </a> </li> <li> <a href="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" title="Permalink to &#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/csi-vegas-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="CSI Vegas" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/csi-vegas-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/csi-vegas-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/csi-vegas-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221; </a> </li> </ul> <ul id="tab2" class="tab-content"> <li> <a href="https://2paragraphs.com/2022/11/donnie-wahlberg-and-derek-gaines-the-new-woody-and-wesley-on-blue-bloods/" title="Permalink to Donnie Wahlberg and Derek Gaines &#8220;The New Woody and Wesley&#8221; on Blue Bloods"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/Derek-Gaines-Donny-W-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Derek Gaines, Donnie Wahlberg on Blue Bloods" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/Derek-Gaines-Donny-W-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/Derek-Gaines-Donny-W-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/Derek-Gaines-Donny-W-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Donnie Wahlberg and Derek Gaines &#8220;The New Woody and Wesley&#8221; on Blue Bloods </a> </li> <li> <a href="https://2paragraphs.com/2022/11/george-lopez-gives-tiktok-star-brice-gonzalez-big-break-on-lopez-vs-lopez/" title="Permalink to George Lopez Gives TikTok Star Brice Gonzalez Big Break on &#8216;Lopez vs. Lopez&#8217;"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/lopez-and-gonzalez-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="lopez vs lopez" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/lopez-and-gonzalez-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/lopez-and-gonzalez-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/lopez-and-gonzalez-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />George Lopez Gives TikTok Star Brice Gonzalez Big Break on &#8216;Lopez vs. Lopez&#8217; </a> </li> <li> <a href="https://2paragraphs.com/2022/11/wwe-diva-becky-lynch-nails-cyndi-lauper-on-young-rock-no-easy-task/" title="Permalink to WWE Diva Becky Lynch Nails Cyndi Lauper on &#8216;Young Rock&#8217; &#8212; &#8220;No Easy Task&#8221;"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/Becky-Lynch-Young-Rock-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Becky Lynch" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/Becky-Lynch-Young-Rock-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/Becky-Lynch-Young-Rock-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/Becky-Lynch-Young-Rock-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />WWE Diva Becky Lynch Nails Cyndi Lauper on &#8216;Young Rock&#8217; &#8212; &#8220;No Easy Task&#8221; </a> </li> <li> <a href="https://2paragraphs.com/2022/11/marlo-thomas-84-pushes-daughters-buttons-in-a-magical-christmas-village-hallmark-movie/" title="Permalink to Marlo Thomas, 84, Pushes Daughter&#8217;s Buttons in &#8216;A Magical Christmas Village&#8217; Hallmark Movie"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/A-Magical-Christmas-Village-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="A Magical Christmas Village (Hallmark/Crown Media)" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/A-Magical-Christmas-Village-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/A-Magical-Christmas-Village-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/A-Magical-Christmas-Village-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Marlo Thomas, 84, Pushes Daughter&#8217;s Buttons in &#8216;A Magical Christmas Village&#8217; Hallmark Movie </a> </li> <li> <a href="https://2paragraphs.com/2022/11/japanese-figure-skater-kaori-sakamoto-crushes-janet-jackson-rock-with-u-routine/" title="Permalink to Japanese Figure Skater Kaori Sakamoto Crushes Janet Jackson &#8216;Rock With U&#8217; Routine"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/11/Kaori-Sakamoto-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Kaori Sakamoto" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/11/Kaori-Sakamoto-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/11/Kaori-Sakamoto-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/11/Kaori-Sakamoto-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Japanese Figure Skater Kaori Sakamoto Crushes Janet Jackson &#8216;Rock With U&#8217; Routine </a> </li> </ul> <ul id="tab3" class="tab-content"> <li> <a href="https://2paragraphs.com/2022/10/getty-museum-making-sense-of-cy-twomblys-enigmatic-perplexing-art/" title="Permalink to Getty Museum &#8220;Making Sense&#8221; of Cy Twombly&#8217;s Enigmatic, Perplexing Art"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/10/Cy-T-Getty-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Cy Twombly in Rome" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/10/Cy-T-Getty-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/10/Cy-T-Getty-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/10/Cy-T-Getty-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Getty Museum &#8220;Making Sense&#8221; of Cy Twombly&#8217;s Enigmatic, Perplexing Art </a> </li> <li> <a href="https://2paragraphs.com/2022/10/marcia-gay-harden-tells-working-moms-put-a-finger-down/" title="Permalink to Marcia Gay Harden Tells Working Moms &#8220;Put a Finger Down&#8221;"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/10/MARCIA-GAY-HARDEN-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Marcia Gay Harden" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/10/MARCIA-GAY-HARDEN-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/10/MARCIA-GAY-HARDEN-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/10/MARCIA-GAY-HARDEN-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Marcia Gay Harden Tells Working Moms &#8220;Put a Finger Down&#8221; </a> </li> <li> <a href="https://2paragraphs.com/2022/10/the-goldbergs-deserves-best-costume-award-for-beverlys-mama-bear-sweater/" title="Permalink to &#8216;The Goldbergs&#8217; Deserves Best Costume Award for Beverly&#8217;s Mama Bear Sweater"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/10/Wendi-mama-bear-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Wendi on The Goldbergs" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/10/Wendi-mama-bear-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/10/Wendi-mama-bear-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/10/Wendi-mama-bear-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />&#8216;The Goldbergs&#8217; Deserves Best Costume Award for Beverly&#8217;s Mama Bear Sweater </a> </li> <li> <a href="https://2paragraphs.com/2022/10/the-conners-debate-who-gains-custody-of-jaded-17-year-old-nephew/" title="Permalink to &#8216;The Conners&#8217; Debate Who Gains Custody of Jaded 17-Year-Old Nephew"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/10/The-Conners-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="The Conners" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/10/The-Conners-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/10/The-Conners-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/10/The-Conners-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />&#8216;The Conners&#8217; Debate Who Gains Custody of Jaded 17-Year-Old Nephew </a> </li> <li> <a href="https://2paragraphs.com/2022/10/rosanna-arquette-filming-with-martin-scorsese-cult-classic-after-hours-co-star-griffin-dunne/" title="Permalink to Rosanna Arquette Reunites With Martin Scorsese &#8216;After Hours&#8217; Co-Star Griffin Dunne, &#8216;Men of Divorce&#8217;"> <img width="150" height="150" src="https://2paragraphs.com/wp-content/uploads/2022/10/Rosanna-Arguette-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Rosanna Arquette" loading="lazy" srcset="https://2paragraphs.com/wp-content/uploads/2022/10/Rosanna-Arguette-150x150.jpg 150w, https://2paragraphs.com/wp-content/uploads/2022/10/Rosanna-Arguette-75x75.jpg 75w, https://2paragraphs.com/wp-content/uploads/2022/10/Rosanna-Arguette-290x290.jpg 290w" sizes="(max-width: 150px) 100vw, 150px" />Rosanna Arquette Reunites With Martin Scorsese &#8216;After Hours&#8217; Co-Star Griffin Dunne, &#8216;Men of Divorce&#8217; </a> </li> </ul> </div> </div> </section> <section class="widget widget-ads-bottom"> <div class="widget-wrap"> <a href="https://apple.news/TjzMU5eWfSSGGvvRmjp-uqw">2paragraphs on APPLE NEWS</a> | <a href="https://amzn.to/3V6Za58">2paragraphs Amazon Shop</a> <br> <div id="amzn-assoc-ad-81ad876f-7da3-474a-8a59-50ba08a58413"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=81ad876f-7da3-474a-8a59-50ba08a58413"></script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3005869422371895" data-ad-slot="2262950850" data-ad-format="auto"></ins> <script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div> </section> <section class="widget widget-ads-bottom"> <div class="widget-wrap"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-3005869422371895" data-ad-slot="6121966473"></ins> <script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> <center> <a href="https://2paragraphs.com">SEE MORE 2paragraphs ARTICLES</a> <br> </div> </section> </div> </aside></div></div> <div class="footer-ad-area"> <div class="wrap"> <div class="footer-ad"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3005869422371895" data-ad-slot="4031328090" data-ad-format="auto"></ins> <script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div> </div> </div> <footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><div class="footer-nav"><ul id="menu-footer" class="menu"><li id="menu-item-1066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1066"><a href="https://2paragraphs.com/about/" itemprop="url">About 2paragraphs</a></li> <li id="menu-item-2583" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-2583"><a href="https://2paragraphs.com/privacy-policy/" itemprop="url">Privacy</a></li> <li id="menu-item-2589" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2589"><a href="https://2paragraphs.com/terms-of-use/" itemprop="url">Terms of Use</a></li> <li id="menu-item-2971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2971"><a href="https://2paragraphs.com/2paragraphs-dedication-page/" itemprop="url">Dedication</a></li> <li id="menu-item-2970" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2970"><a href="https://2paragraphs.com/sitemap.xml" itemprop="url">Map</a></li> <li id="menu-item-27478" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27478"><a href="https://2paragraphs.com/category/fresh-from-the-blogs/" itemprop="url">Fresh</a></li> <li id="menu-item-29602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29602"><a href="https://2paragraphs.com/category/law/" itemprop="url">Law</a></li> <li id="menu-item-36280" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36280"><a href="https://2paragraphs.com/category/how-to/" itemprop="url">How-To</a></li> <li id="menu-item-36281" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36281"><a href="https://2paragraphs.com/category/personal/" itemprop="url">Personal</a></li> <li id="menu-item-141088" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141088"><a href="https://2paragraphs.com/category/books/" itemprop="url">Books</a></li> </ul></div> <p class="copyright">© 2012-2022, 2paragraphs Productions, LLC</p> </div></footer></div><script>
var ssbpTrackGA = function(url,network) {
ga('send', 'event', 'share_buttons', 'Share to '+network, url, {'hitCallback': null});
console.log('Share click pushed to Google Analytics');
}
</script><script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', '', 'auto');
ga('send', 'pageview');
</script><div id="ssbp-ellipsis-div"><span class="ssbp-x ssbp-close-ellipsis-div"></span><a href="https://simplesharebuttons.com/plus/?utm_source=plus&amp;utm_medium=plugin_powered_by&utm_campaign=powered_by&amp;utm_content=plus_ellipsis" target="_blank"><img class="ssbp-ellipsis-powered-by" src="https://2paragraphs.com/wp-content/plugins/simple-share-buttons-plus/images/simple-share-buttons-logo-white.png" alt="Simple Share Buttons" /></a><ul class="ssbp-list"><li class="ssbp-li--buffer"><a href="https://bufferapp.com/add?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/&amp;text= &#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" class="ssbp-btn ssbp-buffer" data-ssbp-title="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Buffer" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Buffer'); return false;"><span class="ssbp-text">Buffer</span></a></li><li class="ssbp-li--diggit"><a href="http://www.digg.com/submit?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" class="ssbp-btn ssbp-diggit" data-ssbp-title="&#8216;CSI: Vegas&#8217; Investigates Bigfoot In Arson Murders, &#8220;That&#8217;s Not Even the Weird Part&#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Digg" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Digg'); return false;"><span class="ssbp-text">Diggit</span></a></li><li class="ssbp-li--email"><a href="/cdn-cgi/l/email-protection#201f7355424a4543541d05121603181211161b6373691a00764547415305121603181211171b00694e5645535449474154455300624947464f4f5400694e006152534f4e006d5552444552530c0005121603181212101b7448415405121603181211171b53006e4f54006556454e00544845007745495244007041525405121603181212111b06414d501b624f44591d05121048545450531a0f0f12504152414752415048530e434f4d0f121012120f11110f4353490d56454741530d494e564553544947415445530d424947464f4f540d494e0d4152534f4e0d4d5552444552530d54484154530d4e4f540d4556454e0d5448450d57454952440d504152540f" class="ssbp-btn ssbp-email ssbp-email-popup" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Email" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Email'); return false;"><span class="ssbp-text">Email</span></a></li><li class="ssbp-li--ellipsis"><a href="javascript:;" class="ssbp-btn ssbp-ellipsis" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Ellipsis"><span class="ssbp-text">More</span></a></li><li class="ssbp-li--facebook"><a data-site="" data-facebook="mobile" class="ssbp-btn ssbp-facebook ssbp-facebook--standard" href="https://www.facebook.com/dialog/share?app_id=775928119208991&display=popup&href=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/&redirect_uri=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/"><span class="ssbp-text">Facebook</span></a></li><li class="ssbp-li--flattr"><a href="https://flattr.com/submit/auto?user_id=&amp;title=%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;&amp;url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" class="ssbp-btn ssbp-flattr" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Flattr" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Flattr'); return false;"><span class="ssbp-text">Flattr</span></a></li><li class="ssbp-li--google"><a href="https://plus.google.com/share?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" class="ssbp-btn ssbp-google" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Google+" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Google+'); return false;"><span class="ssbp-text">Google+</span></a></li><li class="ssbp-li--linkedin"><a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" class="ssbp-btn ssbp-linkedin" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="LinkedIn" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'LinkedIn'); return false;"><span class="ssbp-text">Linkedin</span></a></li><li class="ssbp-li--pinterest"><a href="http://pinterest.com/pin/create/bookmarklet/?is_video=false&url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/&media=https://2paragraphs.com/wp-content/uploads/2022/11/csi-vegas.jpg&description=%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" class="ssbp-btn ssbp-pinterest" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Pinterest_force" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Pinterest'); return false;"><span class="ssbp-text">Pinterest</span></a></li><li class="ssbp-li--print"><a href="#" class="ssbp-btn ssbp-print" onclick="window.print()" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Print"><span class="ssbp-text">Print</span></a></li><li class="ssbp-li--reddit"><a href="http://reddit.com/submit?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/&amp;title=%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" class="ssbp-btn ssbp-reddit" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Reddit" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Reddit'); return false;"><span class="ssbp-text">Reddit</span></a></li><li class="ssbp-li--stumbleupon"><a href="http://www.stumbleupon.com/submit?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/&amp;title=%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" class="ssbp-btn ssbp-stumbleupon" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="StumbleUpon" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'StumbleUpon'); return false;"><span class="ssbp-text">Stumble</span></a></li><li class="ssbp-li--tumblr"><a href="http://www.tumblr.com/share/link?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" class="ssbp-btn ssbp-tumblr" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Tumblr" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Tumblr'); return false;"><span class="ssbp-text">tumblr</span></a></li><li class="ssbp-li--twitter"><a href="https://twitter.com/share?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/&amp;text=%2526%238216%3BCSI%3A+Vegas%2526%238217%3B+Investigates+Bigfoot+In+Arson+Murders%2C+%2526%238220%3BThat%2526%238217%3Bs+Not+Even+the+Weird+Part%2526%238221%3B+&amp;hashtags=" class="ssbp-btn ssbp-twitter ssbp-twitter--standard" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Twitter" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Twitter'); return false;"><span class="ssbp-text">Twitter</span></a></li><li class="ssbp-li--vk"><a href="http://vkontakte.ru/share.php?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" class="ssbp-btn ssbp-vk" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="VK" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'VK'); return false;"><span class="ssbp-text">VK</span></a></li><li class="ssbp-li--whatsapp"><a href="whatsapp://send?text=https%3A%2F%2F2paragraphs.com%2F2022%2F11%2Fcsi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part%2F+%2526%238216%3BCSI%3A+Vegas%2526%238217%3B+Investigates+Bigfoot+In+Arson+Murders%2C+%2526%238220%3BThat%2526%238217%3Bs+Not+Even+the+Weird+Part%2526%238221%3B" class="ssbp-btn ssbp-whatsapp" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="WhatsApp" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'WhatsApp'); return false;"><span class="ssbp-text">WhatsApp</span></a></li><li class="ssbp-li--yummly"><a href="http://www.yummly.com/urb/verify?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/&title=%2526%238216%3BCSI%3A+Vegas%2526%238217%3B+Investigates+Bigfoot+In+Arson+Murders%2C+%2526%238220%3BThat%2526%238217%3Bs+Not+Even+the+Weird+Part%2526%238221%3B" class="ssbp-btn ssbp-yummly" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Yummly" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Yummly'); return false;"><span class="ssbp-text">Yummly</span></a></li><li class="ssbp-li--xing"><a href="https://www.xing.com/spi/shares/new?url=https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" class="ssbp-btn ssbp-xing" data-ssbp-title="%26#8216;CSI: Vegas%26#8217; Investigates Bigfoot In Arson Murders, %26#8220;That%26#8217;s Not Even the Weird Part%26#8221;" data-ssbp-url="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" data-ssbp-site="Xing" onclick="ssbpTrackGA('https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/', 'Xing'); return false;"><span class="ssbp-text">Xing</span></a></li></ul><div class="ssbp-input-url-div"><input class="ssbp-input-url" type="text" value="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" /></div></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
                jQuery("body").on("click", ".ssbp-ellipsis", function() {
                    jQuery("#ssbp-ellipsis-div").fadeIn(500);
                });
                jQuery("body").on("click", ".ssbp-close-ellipsis-div", function() {
                    jQuery("#ssbp-ellipsis-div").fadeOut(500);
                });
              </script><div id="ssbp-email-div"><span class="ssbp-x ssbp-close-email-div"></span><div class="ssbp-email-alert" id="ssbp-email-alert"></div><input type="hidden" id="_wpnonce" name="_wpnonce" value="818ed2076e" /><input type="hidden" name="_wp_http_referer" value="/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" /><form id="js-ssbp-email-form" method="post" action="" data-success-alert-text="Thanks, your email has been sent" data-warning-alert-text="Please check the fields and try again" data-brute-alert-text="The email to friend functionality is restricted to one email every five minutes, please try again soon"> <input type="hidden" id="fill_me" name="fill_me" value="" /> <input type="hidden" id="url" name="url" value="https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" /><input type="hidden" id="_wpnonce" name="_wpnonce" value="818ed2076e" /><input type="hidden" name="_wp_http_referer" value="/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/" /> <div class="ssbp-form-group"> <label for="email" class="ssbp-required">Friend's email</label> <input type="email" class="ssbp-form-control ssbp-required" id="email" name="email" placeholder="friends@email.com" required> </div> <div class="ssbp-form-group"> <label for="message" class="ssbp-required">Message</label> <textarea maxlength="250" class="ssbp-form-control ssbp-required" rows="6" id="message" name="message" required> https://2paragraphs.com/2022/11/csi-vegas-investigates-bigfoot-in-arson-murders-thats-not-even-the-weird-part/</textarea> </div> <div class="ssbp-form-group ssbp-text-align-right"> <button id="ssbp-email-send" type="submit" class="ssbp-btn-primary">Send</button> </div> </form><a href="https://simplesharebuttons.com/plus/?utm_source=plus&amp;utm_medium=plugin_powered_by&utm_campaign=powered_by&amp;utm_content=plus_email" target="_blank"><img class="ssbp-email-powered-by" src="https://2paragraphs.com/wp-content/plugins/simple-share-buttons-plus/images/simple-share-buttons-logo-white.png" alt="Simple Share Buttons" /></a></div><script type="text/javascript">
    amzn_assoc_ad_type = "link_enhancement_widget";
    amzn_assoc_tracking_id = "pralyolianoby-20";
    amzn_assoc_linkid = "053f8a4852e70c5668b3433b77b2ddc5";
    amzn_assoc_placement = "";
    amzn_assoc_marketplace = "amazon";
    amzn_assoc_region = "US";
</script> <script src="//ws-na.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&Operation=GetScript&ID=OneJS&WS=1&MarketPlace=US"></script> <div id="amzn-assoc-ad-05df4739-d248-4a64-ba02-23c2a994bc3d"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=05df4739-d248-4a64-ba02-23c2a994bc3d"></script> <script type="text/javascript">ggv2id='i5sjur7x';</script> <script type="text/javascript" src="https://js.gumgum.com/services.js"></script> <script type="text/javascript" src="https://s.skimresources.com/js/78590X1529353.skimlinks.js"></script> <script type='text/javascript' id='ssbp_standard_callback-js-extra'>
/* <![CDATA[ */
var ssbpAjax = {"ajax_url":"https:\/\/2paragraphs.com\/wp-admin\/admin-ajax.php","security":"ecb24b8997"};
/* ]]> */
</script> <script type='text/javascript' src='https://2paragraphs.com/wp-content/plugins/simple-share-buttons-plus/js/ssbp_standard_tracking.min.js?ver=5.9.5' id='ssbp_standard_callback-js'></script> <script type='text/javascript' id='ssbp_email_send-js-extra'>
/* <![CDATA[ */
var ssbpEmail = {"ajax_url":"https:\/\/2paragraphs.com\/wp-admin\/admin-ajax.php","security":"c62c1d30b6"};
/* ]]> */
</script> <script type='text/javascript' src='https://2paragraphs.com/wp-content/plugins/simple-share-buttons-plus/js/ssbp_email.min.js?ver=5.9.5' id='ssbp_email_send-js'></script> <script type='text/javascript' src='https://2paragraphs.com/wp-includes/js/comment-reply.min.js?ver=5.9.5' id='comment-reply-js'></script> <script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.9.5' async='async' id='remote_sdk-js'></script> <div id="cookie-notice" role="dialog" class="cookie-notice-hidden cookie-revoke-hidden cn-position-bottom" aria-label="Cookie Notice" style="background-color: rgba(0,0,0,1);"><div class="cookie-notice-container" style="color: #fff;"><span id="cn-notice-text" class="cn-text-container">By continuing to use this site you agree to the use of cookies.</span><span id="cn-notice-buttons" class="cn-buttons-container"><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button cn-button-custom button" aria-label="Ok">Ok</a></span><span id="cn-close-notice" data-cookie-set="accept" class="cn-close-icon" title="No"></span></div> </div> </body></html> 